Operating System and Software Requirements

Specific Requirements

JAVA

Orbit Core used by Orbit Desktop and Orbit Server are 100% pure Java. No extra's, just Java. Orbit Desktop and Server run on all platforms that Support Java and provide a Java Runtime Engine.

On Windows, the Java Runtime Engine used by Orbit is included in the Orbit installation.
Java doesn't need to be installed or updated. An existing Java installation won't generate conflicts with Orbit's JRE and visa versa.

There are no differences in Orbit functionality on different platforms.
Except some Orbit Resource Drivers are based on third-party libraries. These drivers might not be available on all platforms, see Supported Geodata Resources.
Some visuals depend the platform due to graphical drivers.

Special note about Java Keystore and SSL Security Certificates, see SSL Certificate to Java Keystore.

Windows

Orbit Desktop Standalone, Desktop Client and Server installations and support are guaranteed on :

  • Desktop : 7, 8 and 10.
  • Server : 2003 (R2), 2008 (R2), 2012 (R2), 2016, 2019 and more recent.

Orbit Desktop Standalone

From Orbit version 11.01) application license, settings and data are stored within the Windows User Application Data directory. Consequently each Operating System user will need to activate Orbit and will manage its own data and preferences.

Linux

Orbit Desktop Client and Server installations and support are guaranteed on Current Ubuntu Releases.

Going for Linux requires the system administrator to have firm knowledge on using and managing the OS.

Distribution, GUI & 3rd Party Software

Each Linux distribution has its own characteristics, we tested and advise Ubuntu.
However as Linux expert you definitely will be able to tune the configuration to run on your preferred distribution.

Orbit Desktop Client requires a graphical user interface, no gui is required to run Orbit Server.
A Linux Orbit Server can serve Orbit Clients running on any platform.

Depending the Orbit Product and configuration some third party software may be required on server and installed by the administrator :

  • Dos2Unix
  • Flash
  • Java
  • MySQL
  • PhpMyAdmin
  • Samba
  • SmbClient
  • SSH Client

Mac OS

Orbit Desktop Standalone installation and support are guaranteed on 10.9, 10.10 and 10.11.

Standards

Orbit Geospatial Technologies is committed to international and interprofessional standards.

  • Most commonly used spatial data storage formats are supported, see Supported Geodata Resources.
  • Only standard Java is used.
  • Orbit Publisher services pure OGC WFS and WMS Web services.
  • Orbit Publisher uses standard Http/Https, XML and Jason communication.
1)
Orbit Desktop Standalone on Windows, remark for older versions < 11.0 : Orbit Desktop products on Windows.
 
Last modified:: 2020/06/16 08:14