Requirements for Orbit 3DM Viewer and Plugins

This page describes the requirements of the Orbit 3DM Viewer and Plugins available for Orbit 3DM Cloud and on-premise Orbit 3DM Publisher.
For legacy Flash Viewer and the Flash-based Plugins for Mobile and Oblique Mapping, see Requirements for Orbit Flash Viewer and Plugins

Generic Requirements

Orbit 3DM Cloud or 3DM Publisher

Orbit 3DM Viewer and Plugins stream data from Orbit 3DM Cloud or Orbit 3DM Publisher to load Resources or a Publication.

The version of 3DM Viewer and derived products (3DM Viewer SDK and 3DM Viewer Plugin) needs to be supported by the backend version of 3DM Cloud or 3DM Publisher. This is guaranteed by design for the 3DM Viewer.
For the 3DM Viewer SDK and Custom User Plugins, it is the responsibility of the Developer. Plugins provided by Orbit are automatically updated to the latest release and thus require an up-to-date Publisher.

Backward compatibility is guaranteed, more recent version of Cloud or Publisher support older versions of 3DM Viewer and derived products. If not, this breaking change will be announced and no auto-redirects will be set.
Forward compatibility is not guaranteed, an older version of Cloud or Publisher might not support a more recent version of the 3DM Viewer and derived products.

Online Connectivity

Orbit 3DM Plugins require access to https://cdn.3dmapping.cloud.
Orbit 3DM Viewer doesn't need online connectivity.

Online data streaming requires a good internet connection (+20Mbps).
Check your internet speed: https://fast.com/.

Browser

Orbit 3DM Viewer and Plugins require an up-to-date version of Chrome, Firefox, Microsoft Edge (Chromium), or Safari.
Internet Explorer and Edge (pre-Chromium) cannot be used because these browsers do not support the required JavaScript libraries and 3D rendering techniques.

WebGL and Graphics Card

Orbit 3DM Viewer and Plugins use GPU (if available) and require the availability of WebGL 1 including the extension EXT_frag_depth for 3D rendering.
If there is no physical graphic card, 3D rendering will be computed in software mode, using a software emulator like “Google SwiftShader” for Google Chrome. Rendering in software mode will reduce the performance of the 3DM Viewer.
Verify if your browser's WebGL compatibility: http://webglreport.com/.

WebSockets

Orbit 3DM Viewer and Plugins require uses WebSocket communication protocol, see https://en.wikipedia.org/wiki/WebSocket.

Plugin Specific Requirements

Verified versions are tested by the Orbit Product Team.
More recent versions of the 3rd party application are expected to be supported as well. Let us know if it doesn't work.
Support for earlier versions is not guaranteed.

Orbit 3DM Plugin for AutoCAD Map 3D

https://www.autodesk.com/
Verified versions: 2019, 2020.

Orbit 3DM Plugin for Esri ArcGIS Desktop

https://www.esri.com/
Verified versions: 10.6, 10.7, 10.8.

Orbit 3DM Plugin for Esri ArcGIS Pro

https://www.esri.com/
Verified versions: 2.5.0, 2.6.0, 2.6.24783, 2.7.0, 2.7.1
Unsupported versions: 2.4.0

Orbit 3DM Plugin for QGIS

https://qgis.org/
Verified versions: 3.4, 3.6, 3.8, 3.10, 3.12, 3.14, 3.16

 
Last modified:: 2021/02/18 09:27