This is documentation of an archived release.
For documentation on the current version, please check Knowledge Base.

Requirements for Orbit 3D Mapping Viewer and Plugins

This page describes the requirements of the Orbit 3D Mapping Viewer and Plugins available for Orbit 3D Mapping Cloud and on-premises Orbit 3DM Publisher.
For legacy Flash Viewer and the Flash-based Plugins for Mobile and Oblique Mapping, see Requirements for Orbit Flash Viewer and Plugins

Generic Requirements

Orbit 3D Mapping Cloud or 3DM Publisher

Orbit 3D Mapping Viewer and Plugins require access to the Orbit 3D Mapping Cloud or an Orbit 3DM Publishers to load Resources or a Publication.

Online Connectivity

Orbit 3D Mapping Plugins require access to https://cdn.3dmapping.cloud.
Orbit 3D Mapping Viewer doesn't need online connectivity.

Browser

Orbit 3D Mapping Viewer and Plugins require an up-to-date version of Chrome, Firefox or Safari.
Internet Explorer and Edge cannot be used because these browsers do not support the required JavaScript libraries and 3D rendering techniques.

Graphics Card

Orbit 3D Mapping Viewer and Plugins require uses GPU and require the availability of WebGL 1 including the extension EXT_frag_depth.
Verify if your browser's WebGL compatibility: http://webglreport.com/.

WebSockets

Orbit 3D Mapping Viewer and Plugins require uses WebSocket communication protocol, see https://en.wikipedia.org/wiki/WebSocket.

Specific Requirements

Orbit 3D Mapping Plugin for AutoCAD Map 3D

  • AutoCad Map 3D : version 2019 and 2020. Support for earlier versions is not guaranteed.
  • System Browser: The plugin requires an up to date browser, see generic browser requirements above.

Orbit 3D Mapping Plugin for Esri ArcGIS Desktop

  • ArcGIS Desktop : version 10.6 and 10.7. Support for earlier versions is not guaranteed.
  • System Browser: The plugin requires an up to date browser, see generic browser requirements above.

Orbit 3D Mapping Plugin for QGIS

  • QGIS Desktop : version 3.4 and more recent versions.
  • System Browser: The plugin requires an up to date browser, see generic browser requirements above.
 
Last modified:: 2020/01/16 17:42